Opslaan in favorieten
Uitgebreid zoeken
Nederlandse versie: Gratis Adivseurs Usa version: Advisors 4 Free Version française: Conseils Gratuits Versione italiana: consigligratuiti.it Belgische versie: gratisadviseurs.be Versión española : Consejeros Gratis Deutsche Version: Gratis Beraten
U bevindt zich hier:Home » Computers » Computersoftware » Office Suites » Microsoft Excel
Adverteren op deze site?

Direct vraag stellen?

Stel online je vraag in de rubriek Microsoft excel en krijg online een antwoord van de specialist in Microsoft excel

Zelf een vraag over Microsoft excel? Klik hier.
Meer vragen over Microsoft excel.
De huidige beheerder van de rubriek Microsoft excel:
Naam: Sandy
Bedrijf: Zzp
Reactiesnelheid: 105 uur
Waardering: 8.6 (van max. 10)
Meer informatie over Sandy vind je op de profielpagina.

Beheerder worden?

RSS over Microsoft excelVragen over Microsoft excel via RSS. Klik hier.
RSS over Microsoft excel op jouw website?Vragen over Microsoft excel op jouw website? Klik hier.
Blijf op de hoogte via e-mail over Microsoft excelVragen over Microsoft excel via E-mail. Klik hier.

Hoe kan je rekenen met tijd (datum overschrijdend)

[Gesteld op: 03-11-2017]

Toelichting:
Ik zoek een functie om te rekenen met tijd en kosten: van 07u tem 23u heb ik een kost van €0,1, van 23u tot 7u de volgende ochtend heb ik een kost van €0,2.

Ik zou graag berekenen hoeveel het mij kost van 14u op dag 1 tot 12u op dag 2. Enig idee hoe dit met een formule kan?
Antwoord:

Dat is best ingewikkeld!


Ik heb een opzetje gemaakt maar kan in deze editor niks grafisch plakken. Daarom hieronder de beschrijving per cel. Als je dit namaakt kun je zien hoe je met tijd datumoverschrijdend kunt rekenen. Ik heb voor tarief 2 het resultaat uit elkaar getrokken met een urenaantal op de eerste dag (2-1) en een aantal op de tweede dag (2-2).
Met deze getallen kun je verder rekenen voor een tarief.


Ik heb niet alle situaties nagebootst, dus wellicht is het niet helemaal foutloos, maar hiermee heb je al wel een handvat om het verder uit te werken.


Succes!


A1: "Tarief 1"
B1: 07:00 (celeigenschap: tijd)
C1: 23:00 (celeigenschap: tijd)
D1: 0:00 (celeigenschap: tijd)
A2: "Tarief 2"
B1: 23:00 (celeigenschap: tijd)
C1: 07:00 (celeigenschap: tijd)
A4: "Starttijd"
B4: "Startdatum"
C4: "Eindtijd"
D4: "Einddatum"
E4: "Uren tarief 1"
F4: "Uren tarief 2-1"
G4: "Uren tarief 2-2"
A5: 14:00 (celeigenschap: tijd)
B5: 01-11-2017 (celeigenschap: datum)
C5: 12:00 (celeigenschap: tijd)
D5: 02-11-2017 (celeigenschap: datum)
E5: =ALS(EN(A5>B1;A5B5;C5>B1);(C5-B1)*24;0) (celeigenschap: getal)
F5: =ALS(D5>B5;ALS(A5G5: =ALS(D5>B5;ALS(C5

 
Reactie vraagsteller:
Dank u wel voor dit antwoord! Het ziet er al veelbelovend uit! Ik heb uw opzet proberen na te maken in excel, maar blijkbaar zijn de functies van cellen E5 en F5 niet helemaal gekopieerd...

In E5 staat er: ALS(EN(A5>B1;A5B5;C5>B1);(C5-B1)*24;0) dit neemt excel niet aan omdat er tussen A5B5 een teken ontbreekt. wat had u daar tussen gezet?

In F5 staat er ALS(D5>B5;ALS(A5G5: =ALS(D5>B5;ALS(C5 ook hier ontbreekt er een teken tussen A5G5 en vermoed ik dat de functie onvolledig in dit antwoord gekopieerd werd...

Kan u mij de ontworpen functies van bovenvernoemde cellen nog eens doorsturen?

Welke functie moet er in G5 komen?
 
Antwoord Beheerder:

Er ontbreekt blijkbaar een groter deel van de formule. Nogmaals:


E5: =ALS(EN(A5>B1;A5<C1);(C1-A5)*24;0)+ALS(EN(D5>B5;C5>B1);(C5-B1)*24;0) 
F5: =ALS(D5>B5;ALS(A5<B2;1;D1-A5);0)
G5: =ALS(D5>B5;ALS(C5<C2;(D1-C5)*-1;7);0)


Alle drie de cellen krijgen celeigenschap "getal".


Het is helaas technisch niet mogelijk om weer op dit antwoord te reageren. Mocht er nog iets niet werken, dan kan dat in een nieuwe vraag.


Succes!

Beantwoord door:
Sandy
profielpagina


Gerelateerde vragen aan Hoe kan je rekenen met tijd (datum overschrijdend):

oznur
      [Gesteld in Plastische Chirurgie]
2007-03-13 23:37:04
wanneer loon na ontslag?
      [Gesteld in Advocaten-Friesland]
2008-07-18 11:00:06
verdelen contracturen
      [Gesteld in Arbeidsrecht-Zuid Holland]
2010-07-04 22:54:11
Werken na vroegpensioen nieuwe werkgever.
      [Gesteld in Belastingen-Zeeland]
2011-01-14 19:13:33
Bedrijf verkopen,maar verhuurder wil niet meewerke
      [Gesteld in Zakelijke Dienstverlening]
2012-03-27 21:45:55

Gemiddelde score Microsoft excel: 8.4 (48x gestemd)

Wat voor cijfer geeft u dit antwoord?

 
10

 
Versturen via e-mail aan vrienden?
 
Uw Naam:
Uw Email:
Naam bekende:
Email bekende:
+ meer vrienden invoeren
 
Message:
Check:
 



Disclaimer | Sitemap | Archief | Links | 100 laatste vragen | Populair archief

Top 3 adviseurs

Uw banner hier?

Concept & Realisatie Webshop+