Opslaan in favorieten
Uitgebreid zoeken
Nederlandse versie: Gratis Adivseurs Usa version: Advisors 4 Free Version franšaise: Conseils Gratuits Versione italiana: consigligratuiti.it Belgische versie: gratisadviseurs.be Versiˇn espa˝ola : Consejeros Gratis Deutsche Version: Gratis Beraten
U bevindt zich hier:Home » Computers » Computersoftware » Office Suites » Microsoft Excel
Adverteren op deze site?

Direct vraag stellen?

Stel online je vraag in de rubriek Microsoft excel en krijg online een antwoord van de specialist in Microsoft excel

Zelf een vraag over Microsoft excel? Klik hier.
Meer vragen over Microsoft excel.
De huidige beheerder van de rubriek Microsoft excel:
Naam: Sandy
Bedrijf: Zzp
Reactiesnelheid: 104 uur
Waardering: 8.6 (van max. 10)
Meer informatie over Sandy vind je op de profielpagina.

Beheerder worden?

RSS over Microsoft excelVragen over Microsoft excel via RSS. Klik hier.
RSS over Microsoft excel op jouw website?Vragen over Microsoft excel op jouw website? Klik hier.
Blijf op de hoogte via e-mail over Microsoft excelVragen over Microsoft excel via E-mail. Klik hier.

Gegevens van twee Excel files bijeen zoeken

[Gesteld op: 02-08-2013]

Toelichting:
Ik heb twee Excel files, A en B. Ik wil dat Excel kijkt in b.v. kolom A in beide files, is er een gelijk getal (b.v. debiteurennummer) dan moet ie uit file B de gegevens van een cel kopiŰren naar de regel in file A in een bepaalde cel. Dus vergelijken en als de waarde gelijk is dan iets kopieŰren. Kan dat?
Antwoord:

Ja, dat kan. Ik leg het uit met als voorbeeld de bestanden Map1 en Map2. Map1 is het ontvangende bestand en de vaste gegevens staan in Map2.

In Map1-cel B1 staat in mijn voorbeeld het nummer waarop moet worden gezocht (bijv. deb.nr.). Dit is de sleutel. De sleutel wordt in Map2 gezocht in het bereik A1:G10 en de gegevens staan in de rij achter de sleutel. Bijvoorbeeld: 

  • A1: deb.nr.
  • B1: deb.naam
  • C1: adres
  • D1: postcode
  • enz.

In Map1-cel B1 wordt de sleutel ingevuld. In de cel in Map1 waar ik het gegeven uit Map2-kolom B wil hebben zet ik de volgende formule:

=VERT.ZOEKEN(B1;[Map2.xlsx]Blad1!$A$1:$G$10;2)

De syntaxis is: =VERT.ZOEKEN(sleutel;bereik;kolom)

Het getal dat helemaal aan het eind staat (2) verwijst naar de hoeveelste kolom in het bereik waar het gegeven uitgehaald moet worden. Het bereik is Map2-A1 t/m G10, dus 1 geeft het gegeven uit kolom A, 2 uit kolom B, 3 uit kolom C, enz. Dat betekent dat in de cel waar ik het gegeven uit kolom C wil hebben een andere formule komt, namelijk:

=VERT.ZOEKEN(B1;[Map2.xlsx]Blad1!$A$1:$G$10;3)

Map2 hoeft niet geopend te zijn. Ik heb het niet getest, maar vermoedelijk moeten beide bestanden wel in dezelfde map staan.

Ik hoop dat dit de oplossing is. Succes verder!

 

 

 
Reactie vraagsteller:
Een 10 met een griffel! ;-) Dank je!
 
Antwoord Beheerder:
Fijn dat het is gelukt en bedankt voor het compliment!
Beantwoord door:
Sandy
profielpagina


Gerelateerde vragen aan Gegevens van twee Excel files bijeen zoeken:

risico's bilvergroting
      [Gesteld in Plastische Chirurgie]
2008-02-28 19:39:51
Mag een foto ongevraagd gepubliceerd worden?
      [Gesteld in Televisie]
2010-03-10 16:44:04
portretrecht ja of nee?
      [Gesteld in Televisie]
2010-03-19 16:48:08
Pompleiding vervangen door grotere leiding+pomp
      [Gesteld in Natuurkunde]
2010-10-19 18:16:32
Bedrijf verkopen,maar verhuurder wil niet meewerke
      [Gesteld in Zakelijke Dienstverlening]
2012-03-27 21:45:55

Gemiddelde score Microsoft excel: 8.4 (48x gestemd)

Wat voor cijfer geeft u dit antwoord?

 
10

 
Versturen via e-mail aan vrienden?
 
Uw Naam:
Uw Email:
Naam bekende:
Email bekende:
+ meer vrienden invoeren
 
Message:
Check:
 



Disclaimer | Sitemap | Archief | Links | 100 laatste vragen | Populair archief

Top 3 adviseurs

Uw banner hier?

Concept & Realisatie Webshop+